Thursday, January 24

How to Install New AMD Catalyst 13.1 Legacy Driver in Ubuntu 12.10

AMD Catalyst Legacy driver for Linux (compatible with series 2xxx-4xxx cards) has been updated to version 13.1.

This release features some fixes needed by Team Fortress 2 and other Linux games on Steam.

Unfortunately, this driver supports Ubuntu 12.04 LTS only which comes with xorg 1.12. Ubuntu 12.10 ships with xorg 1.13, so in order to use this driver on Ubuntu 12.10, you will have to downgrade to xorg 1.12.

Tomasz Makarewicz has updated his PPA (big thanks to him!!), providing an easy way to downgrade xorg and install patched Catalyst Legacy 13.1 (fglrx 8.97.100.7) driver that works with Linux kernel 3.5 on Ubuntu 12.10.

If you have followed our last post and already added the PPA, just run Software Updater to get the new version.

Run the commands below to install AMD Catalyst Legacy 13.1 driver if you haven't added the PPA yet (Ubuntu 12.10 only).

sudo add-apt-repository ppa:makson96/fglrx
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install fglrx-legacy

Do note that these packages are not officially supported by Ubuntu, so use them at your own risk. If something goes wrong, you can purge the packages by running following commands:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:makson96/fglrx

0 comments:

Post a Comment

Preload Image 1 Preload Image 2 Preload Image 3 Preload Image 4 Preload Image 5